Critical Flaws Patched in MailStore Server

An update released earlier this month for MailStore Server patches a couple of cross-site scripting (XSS) and open redirect vulnerabilities found by a researcher from Germany-based security firm Secuvera.

MailStore Server is one of the most widely used solutions for email archiving, management and compliance.

An update released earlier this month for MailStore Server patches a couple of cross-site scripting (XSS) and open redirect vulnerabilities found by a researcher from Germany-based security firm Secuvera.

MailStore Server is one of the most widely used solutions for email archiving, management and compliance. According to MailStore, the product is used by thousands of organizations around the world, including private companies and government agencies.

The security holes, classified by MailStore as “critical,” affect Web Access, the component that allows users to access their mail archive through a web browser.

Secuvera’s Tobias Glemser discovered that MailStore Server’s Web Access component did not properly filter user input, allowing malicious actors to launch both XSS and open redirect attacks.

The reflected XSS flaw, which affects the search function in Web Access, can allow an attacker to gain access to an organization’s email archive by getting an authenticated user to click on a specially crafted link.

The open redirect vulnerability, which affects the dereferrer component, can be exploited by an attacker to lure users to a potentially malicious website by tricking them into clicking on a specially crafted link that appears to point to a trusted domain. The user does not need to be authenticated for the attack to work.

The XSS vulnerability affects MailStore Server 9.2 and newer, while the open redirect issue affects version 9.0 and newer. The flaws were reported to the vendor on January 9 and they were patched on January 18 with the release of version 10.0.2. MailStore has advised users to update their installations as soon as possible.

Only a few MailStore Server vulnerabilities have been disclosed in the past years, including one in 2016 and two in 2014.

Related Reading: Critical Vulnerability in Symantec AV Engine Exploited by Just Sending an Email

Related Reading: Hackers Can Exploit Roundcube Flaw by Sending an Email

Related Reading:Yahoo Pays Out $10,000 Bounty for Critical Mail Flaw

Register for the 2017 CISO Forum at Half Moon Bay

2017 ICS Cyber Security Conference | Singapore [April 25-27]

View Our Library of on Demand Security Webcasts

Leave a Reply

Your email address will not be published. Required fields are marked *